Spacemail service issue

Incident Report for HugoFox

Resolved

Resolved — Spacemail service issue
The Spacemail issue has now been fully resolved and email should be working as normal again.

If you're still experiencing any problems, missing emails, folder issues, or error messages, please get in touch at team@hugofox.com and we'll make sure it's sorted for you right away.

Thanks for bearing with us today.
Posted May 26, 2026 - 17:49 UTC

Monitoring

Update - Spacemail service issue:
Spacemail have confirmed that the main issue has now been resolved. However, some mailboxes are still affected, you may still see emails missing from webmail or an error message when trying to access your account.

Their technical team is working with the highest priority to fix the remaining affected mailboxes. There's no estimated time yet for when this will be fully complete, but no emails or data will be lost.

We'll update this page again as soon as we hear more. In the meantime, please bear with us — and feel free to get in touch at team@hugofox.com if you have any concerns.
Posted May 26, 2026 - 14:06 UTC

Identified

We're aware that some clients are currently experiencing problems with Spacemail. You may find that certain emails or folders aren't showing correctly in webmail, or you may see an error message when trying to access your account.

The good news: most functionality should still be working, and no emails or data will be lost. Spacemail's team is investigating and working to bring everything fully back online as soon as possible.

We'll update this page as we hear more. If you have any concerns in the meantime, please feel free to get in touch at team@hugofox.com
Posted May 26, 2026 - 11:26 UTC
This incident affected: Emails (Spacemail).