Resolved: All HugoFox sites are now back online and operating normally. The upstream issue affecting our certificate provider has been fixed and full service has been restored.
If you're still experiencing any problems, please get in touch, email team@hugofox.com or call 01635 888 442, and we'll look into it straight away.
Thank you for bearing with us.
Posted May 08, 2026 - 21:27 UTC
Identified
Update: We've identified today's issue as a service disruption at Let's Encrypt, the certificate authority we use to provide SSL for HugoFox sites. While the underlying cause is outside our direct control, our team is applying a workaround now and affected sites are coming back online progressively.
Thank you for your patience — we'll post another update once everything is fully restored.
Posted May 08, 2026 - 19:51 UTC
Investigating
We're aware of an SSL issue currently affecting some HugoFox sites. Our team is investigating and we expect to have this resolved shortly. We'll update this page as soon as we have more information.