The server upgrade is now complete and all HugoFox systems are fully operational. Website speeds should now be back to normal, with further performance improvements expected over the coming week as the new infrastructure settles in fully.
We sincerely apologise for the extended disruption and for the additional time this upgrade has taken. Thank you for your patience.
Posted Apr 16, 2026 - 11:49 UTC
Update
We are continuing to monitor for any further issues.
Posted Apr 15, 2026 - 00:48 UTC
Monitoring
We are currently performing scheduled server maintenance as part of an upgrade to faster, more secure infrastructure. During this time, you may experience brief periods of downtime across most systems, as well as some slower-than-usual website performance.
Email and support channels remain fully operational and are unaffected by this maintenance.
We expect all systems to return to normal shortly. This status page will be updated once the upgrade is complete. Thank you for your patience.
Posted Apr 13, 2026 - 10:37 UTC
This incident affected: Client sites, HF front end, CMS, Servers, Support, and Emails (Spacemail).